Bug #2004

Users can't download attachments from invisible forum

Added by bosit man almost 2 years ago. Updated almost 2 years ago.

Status:RejectedStart date:04/29/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Reproducibility:Always Database Type:
Reported In MyBB Version:1.6.7 Database Version:
PHP Version: SQA assignments:
Browser:

Description

If you have a forum hidden from a usergroup, but you have explicitly enabled 'Can download attachments' on the forum permissions for that usergroup, the users still can't download attachments by linking to them directly (like http://www.myforum.com/attachment.php?aid=xxx )

To replicate:
1)Create a forum and remove all permissions from a usergroup of your choice to it
2)Edit the permissions for that usergroup on that forum and only enable 'Can download attachments'
3)Users of group still cannot download attachments with a link to it

History

#1 Updated by Stefan T. almost 2 years ago

  • Status changed from New to Rejected

That's intended, you can't download attachments you can't see...

Also available in: Atom PDF