Bug #600

Intensive loop in functions_time.php

Added by Ryan Gordon over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:12/19/2009
Priority:NormalDue date:
Assignee:Ryan Gordon% Done:

100%

Category:Performance
Target version:1.4.11
Reproducibility:Rarely Database Type:
Reported In MyBB Version:1.4.10 Database Version:
PHP Version: SQA assignments:
Browser:

Description

Under very certain and rare circumstances, it is possible to make a portion of code in functions_time.php (a loop) run millions of times before it stops. This can cause long page loads where functions_time.php is used (just the member.php page by the looks of it) and raise the server load. Therefore this is being categorized as a performance issue. The fix is small and simple and will be updated in the MyBB 1.4.10 package. An announcement on the MyBB blog will be made for those users who wish to apply the fix [it will be recommended]. A new release will not be made considering the severity of this problem is minimal and because a MyBB 1.6 release is not too far out.

History

#1 Updated by Ryan Gordon over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r4613.

#2 Updated by Dennis Tsang over 4 years ago

  • Target version changed from 1.4.10 to 1.4.11

#3 Updated by Dennis Tsang over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF