Bug #628

Lang for portal login in wrong file

Added by Ryan Wagoner over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:01/01/2010
Priority:NormalDue date:
Assignee:Tom Moore% Done:

100%

Category:Portal
Target version:1.6.0 Beta
Reproducibility:Always Database Type:
Reported In MyBB Version:1.4.10 Database Version:
PHP Version: SQA assignments:
Browser:

Description

The portal needs error_invalidpworusername for the login code. Currently this lang string is located in the member.lang.php file and should be moved to the messages.lang.php file. This causes the "An unknown error has occurred." message to be displayed instead of the invalid password or username message.

History

#1 Updated by Tom Moore over 4 years ago

  • Category set to Portal
  • Status changed from New to Assigned
  • Assignee set to Tom Moore
  • Target version set to 1.4.12

#2 Updated by Tom Moore over 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Applied in changeset r4700.

To prevent language changes so late in a 1.4.x release, I've just linked the member.lang.php file in the portal. For 1.6, I've moved the language string itself to messages.lang.php.

#3 Updated by Tom Moore over 4 years ago

Applied in changeset r4712.

#4 Updated by Tom Moore over 4 years ago

  • Target version changed from 1.4.12 to 1.6.0 Beta

Target version for this change is 1.6; changes to the 1.4 branch have been reverted in r4712.

#5 Updated by Stefan T. about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF