Bug #809

Unviewable threads showing on portal

Added by Matt Rogowski over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:03/15/2010
Priority:NormalDue date:
Assignee:Huji Lee% Done:

100%

Category:Portal
Target version:1.4.12
Reproducibility:Always Database Type:
Reported In MyBB Version:1.4.11 Database Version:
PHP Version: SQA assignments:
Browser:

Description

Originally reported here: http://community.mybboard.net/thread-66255.html

If you set a forum to be visible, but hide the threads inside it, the titles will still show on the latest posts section of the portal. Suggested fix:

Line 106 of ./portal.php:

$unviewable = get_unviewable_forums();

change to:

$unviewable = get_unviewable_forums(true);

The get_unviewable_forums() function has a parameter to 'only fetch those forums for which users can actually read a thread in', and it's necessary to use this here.


Related issues

Related to MyBB - Bug #749: Portal "Since then, there have been:" counts unapproved t... Closed 02/11/2010

History

#1 Updated by Huji Lee over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Huji Lee
  • Target version set to 1.4.12

#2 Updated by Huji Lee over 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Applied in changeset r4813.

#3 Updated by Stefan T. over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF